wiki:OpenWrt/wireless/access_point

Version 2 (modified by Tim Harvey, 6 years ago) ( diff )

fix broken link

This information has been tested and created for use on the Gateworks Single Board Computers (SBCs), specifically the Ventana family that utilizes the Freescale i.MX6 processors.

Gateworks SBCs can be viewed at the following link: http://www.gateworks.com

http://trac.gateworks.com/raw-attachment/wiki/OpenWrt/wireless/relayd/gw5100realsmall.png

OpenWrt Access Point Configuration

A generic Wireless Access Point (commonly known as a WAP or Wireless AP) is likely the most common configuration and is what OpenWrt defaults to when a new radio is detected.

There are 2 ways to configure:

  1. Web-Interface - a GUI that may be easier for some users. See tutorial to connect to the board: Accessing the Web Interface
  2. shell via the command-line

Configuring an Access Point from the shell

You can see this by checking the file on the Gateworks board /etc/config/wireless.

root@OpenWrt:/# cat /etc/config/wireless 
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11ng
        option phy      phy0
        option htmode   HT20
        list ht_capab   LDPC
        list ht_capab   SHORT-GI-20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrtGateworks
        option encryption none

Configuring an Access Point via GUI

  1. Connect the board to the network through the Ethernet 1 interface.
  1. Click on the Network tab, then the Interfaces tab. By default there should be an interface called “lan.”

  1. Edit the interface by either clicking on the LAN tab or by clicking on the icon under the Actions section with alt text “Edit this interface.”

  1. Click on the General Setup tab under Common Configuration. (This should already be selected).
  1. Change the IP address in the IPv4-Address field to an available address on the network. This is only necessary if the current address (192.168.1.1) is not part of the network or is already being used on the network.
  1. Add the gateway and DNS for the network into the IPv4-Gateway and DNS-Server fields respectively. If the networks gateway is 192.168.1.1, it might look something like this:

  1. Click on Save at the bottom of the screen. (Do not click on Save & Apply yet. Otherwise step 11 must be completed to access the board again.)
  1. Click on the Physical Settings tab next to the General Setup tab.
  1. Make sure the boxes next “creates a bridge over specified interface(s)” and “Ethernet Adapter: ‘eth0’” are checked. If not, check them.
  1. Check the box next to“Ethernet Adapter: eth1”

  1. Click on Save & Apply at the bottom of the screen. If the IP address was changed in step 9, the address in the address bar of the browser must be changed to the new IP address. In this case the IP address was changed to 192.168.1.10.
  1. Enter the username and password to login and access the board again.

Configuring the Wifi

  1. Connect a wireless card to any of the four PCI slots on the board.
  1. Reboot the board and login again.
  1. Click on the Network tab, then the Wifi tab.
  1. The wireless card should show up under Wireless Overview.

  1. Edit the Wireless Controller by clicking on the icon with alt text “Edit this network.”
  1. Click on the General Setup tab under Device Configuration. (This should already be selected).
  1. Check the box next to “Enable device.”
  1. Click on Save & Apply at the bottom of the screen.
  1. Click on the General Setup tab under Interface Configuration. (This should already be selected).
  1. Change ESSID to a desired name.
  1. Make sure Mode is set to Access Point.
  1. Change Network to “lan”

  1. Click on Save at the bottom of the screen.
  1. Click on the Wireless Security tab next to the General Setup tab.
  1. Set desired wireless security settings. In this case the Encryption is set to WPA-PSK and a key is chosen.

  1. Click on Save & Apply at the bottom of the screen.
  1. The board should now be acting as an access point.

Multiple Access Points per radios (Multiple SSID's)

Another common configuration is to have multiple Access Points (multiple SSID's) on a physical radio. In this case, there are multiple 'wifi-iface' config sections linking to a specific 'wifi-device' config section. This is sometimes known as Virtual Access Points and each Access Point shares the same radio configuration (channel, band, modes)

This is useful to allow different groups of people with different permissions (each group using a different SSID's on the same radio). Each Virtual Access Point can have its own network configuration, SSID, and security configurations.

To configure this from the GUI, select Network -> Wifi and click the 'Add' Button in the top right. This will add another interface with a new SSID connected to the same radio.

To configure this from the shell you would use UCI commands or edit /etc/config/wireless to create multiple 'config wifi-iface' sections that points to the same 'wifi-device' specified via the 'device' option in the wifi-iface section.

For example:

root@OpenWrt:/# cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option phy 'phy0'
        option htmode 'HT20'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'

config wifi-iface
        option device 'radio0'
        option network 'ap1'
        option mode 'ap'
        option ssid 'OpenWrt-AP1'
        option encryption 'none'

config wifi-iface
        option device 'radio0'
        option network 'ap2'
        option mode 'ap'
        option ssid 'OpenWrt-AP2'
        option encryption 'none'

Attachments (9)

Download all attachments as: .zip

Note: See TracWiki for help on using the wiki.