wiki:OpenWrt/wireless/client

OpenWrt Wireless Client

If you want to provide a bridge between a Wireless Access Point and an Ethernet LAN you need a Wireless Bridge and not a standard wireless client. Please see our wiki about Wireless Bridging

If the bridge is not needed, you can configure a Gateworks board as a standard Wireless client like in the following example:

  • Configure the /etc/config/wireless file
    root@OpenWrt:/# cat /etc/config/wireless 
    
    config wifi-device 'radio0'
            option type 'mac80211'
            option channel '11'
            option hwmode '11g'
            option phy 'phy0'
            option txpower '27'
            option country 'US'
            option disabled '0'
    
    config wifi-iface
            option network 'wwan'
            option ssid 'myap'
            option encryption 'psk2'
            option device 'radio0'
            option mode 'sta'
            option bssid '00:23:69:D2:37:7E'
            option key 'abc123'
    
  • Configure the /etc/config/network file

If something is connected to the ethernet port on that board and would like to also connect, you can create a different subnet (192.168.2.x) for the ethernet and let the wireless (192.168.1.x) act like the wan.

root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.76'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'wlan0'
        option proto 'static'
        option ipaddr '192.168.1.76'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config interface 'wwan'
        option proto 'dhcp'
Last modified 2 years ago Last modified on 03/02/15 09:28:12